Service issue affecting SORACOM Funnel and AWS IoT Core
Incident Report for SORACOM
Resolved
English follows after Japanese

日本時間 2020/12/16 19:30 頃より 2020/12/17 14:40 頃まで、SORACOM Funnel から AWS IoT Core へのデータ送信が一部失敗しておりました。原因の対処とその経過観察が完了しており、現在は平常通りご利用いただけます。このたびはご迷惑をおかけし、誠に申し訳ございませんでした。当事象のタイムライン (日本時間) は以下となります。

- 2020/12/16 19:30 頃 事象開始
- 2020/12/17 14:40 頃 対処実施、経過観察開始
- 2020/12/17 15:40 頃 事象復旧を確認

影響範囲は、以下リージョンの AWS IoT Core へ送信していた SORACOM Funnel のデータです。これらについてはエラーログに送信データが記載されておりますが、AWS IoT Core へは送信されておらず、再送もされません。

- ap-northeast-1
- ap-northeast-2
- ap-southeast-1
- ap-southeast-2
- cn-north-1
- eu-central-1
- eu-west-1
- eu-west-2
- us-east-1
- us-east-2
- us-west-2

---

The issue that caused failures to occur when using Soracom Funnel to send data to AWS IoT Core beginning on 2020-12-16 10:30 UTC has been resolved as of 2020-12-17 05:40 UTC. The service is now operating normally. We sincerely apologize for any inconvenience caused during this time. Detailed Timeline (UTC) follows:

- 2020/12/16 10:30: The issue began
- 2020/12/17 05:40: Implemented the fix, begin monitoring
- 2020/12/17 06:40: Confirmed recover

The issue impacted data sent to AWS IoT Core in following regions. Affected data was not sent to AWS IoT Core, and will not be resent. However, you can view the data in Soracom Error Logs.

- ap-northeast-1
- ap-northeast-2
- ap-southeast-1
- ap-southeast-2
- cn-north-1
- eu-central-1
- eu-west-1
- eu-west-2
- us-east-1
- us-east-2
- us-west-2
Posted Dec 17, 2020 - 15:54 JST
Monitoring
English follows after Japanese
SORACOM Funnel より AWS IoT Core へのデータ送信が失敗する状況について、対策を実施して復旧中です。現在、通常どおりのサービスレベルに戻るまで経過を観察しています。完全な復旧が確認されたら改めてこちらのページでお知らせいたします。
---
We have identified the issue that caused failures to occur when using Soracom Funnel to send data to AWS IoT Core, and have implemented a fix. We are currently monitoring our networking components as the service is recovering, and will update this page once the service has fully restored.
Posted Dec 17, 2020 - 14:42 JST
Investigating
English follows after Japanese

SORACOM Funnel より AWS IoT Core へのデータ送信が一部失敗する状況となっております。エンジニアチームが調査を行っております。
---
Our engineering team has observed an increase in the number of failures when using Soracom Funnel to send data to AWS IoT Core, and is currently investigating the issue.
Posted Dec 17, 2020 - 14:25 JST
This incident affected: Funnel (plan01s (rendezvous point : Germany), plan01s (rendezvous point : United States), plan01s (rendezvous point : Japan), planX1 (rendezvous point : Germany), planX1 (rendezvous point : United States), planX1 (rendezvous point : Japan), planP1 (rendezvous point : Germany), planP1 (rendezvous point : United States), planP1 (rendezvous point : Japan), plan-D, plan-K, plan-DU, plan-KM1).