Service issue affecting SORACOM Funnel and AWS IoT Core
Incident Report for SORACOM
Resolved
English follows after Japanese
日本時間 2020/12/17 14:40 頃より 2020/12/17 17:55 頃まで、SORACOM Funnel から AWS IoT Core へのデータ送信が一部失敗しておりました。原因の対処とその経過観察が完了しており、現在は平常通りご利用いただけます。このたびはご迷惑をおかけし、誠に申し訳ございませんでした。当事象のタイムライン (日本時間) は以下となります。

- 2020/12/17 14:40 頃 事象開始
- 2020/12/17 17:10 頃 大部分の復旧を確認
- 2020/12/17 17:55 頃 全体の復旧を確認

影響範囲は、以下リージョンの AWS IoT Core へ送信していた SORACOM Funnel のデータです。これらについてはエラーログに送信データが記載されておりますが、AWS IoT Core へは送信されておらず、再送もされません。

- 日本カバレッジ: ap-northeast-1 以外のリージョン
- グローバルカバレッジ: 全てのリージョン

なお、送信先 AWS IoT Core のエンドポイントが https://data.iot.[リージョン名].amazonaws.com となっている場合は現時点でも SORACOM Funnel からの送信に失敗します。こちらについては、このエンドポイントで使用されているTLS証明書が、無効な証明書であるためです。このような設定となっている場合は、カスタムエンドポイント (ATS エンドポイント) を利用するよう設定の変更をお願いします。詳細に関しては、https://aws.amazon.com/jp/blogs/news/aws-iot-core-ats-endpoints/ を参照ください。

---

An issue in which attempts to send data from Soracom Funnel to AWS IoT Core failed starting at 2020-12-17 05:40 UTC has been resolved as of 2020-12-17 08:55 UTC. The service is now operating normally. We sincerely apologize for any inconvenience caused during this time. The detailed timeline (UTC) is as follows:

- 2020/12/17 05:40: Issue began
- 2020/12/17 08:10: Most service recovered
- 2020/12/17 08:55: All service recovered

The issue impacted data sent to AWS IoT Core in the following regions:

- Global Coverage: All regions
- Japan Coverage: Regions other than ap-northeast-1

Affected data was not sent to AWS IoT Core and will not be re-sent, but can be viewed in Soracom error logs.

Please note that data transmission failure will still occur for AWS IoT Core endpoints of https://data.iot.[REGION_NAME].amazonaws.com, as the TLS certificate used for this endpoint is invalid. In this case, please configure a custom endpoint (ATS endpoint) as shown in https://aws.amazon.com/jp/blogs/iot/aws-iot-core-ats-endpoints/.
Posted Dec 17, 2020 - 19:28 JST
Monitoring
English follows after Japanese

SORACOM Funnel より 以下のリージョンへの AWS IoT Core へのデータ送信が失敗する状況となっておりました。エンジニアチームが調査・対処を実施し、現在は通常どおりのサービスレベルに戻るまで経過を観察しています。完全な復旧が確認されたら改めてこちらのページでお知らせいたします。

- 日本カバレッジ: ap-northeast-1 以外のリージョン
- グローバルカバレッジ: 全てのリージョン

---

We have identified the issue that caused failures to occur when using Soracom Funnel to send data to AWS IoT Core of following regions and have implemented a fix. We are currently monitoring our networking components as the service is recovering and will update this page once the service has fully restored.

- Global Coverage: All regions
- Japan Coverage: Regions other than ap-northeast-1
Posted Dec 17, 2020 - 17:19 JST
This incident affected: Funnel (plan01s (rendezvous point : Germany), plan01s (rendezvous point : United States), plan01s (rendezvous point : Japan), planX1 (rendezvous point : Germany), planX1 (rendezvous point : United States), planX1 (rendezvous point : Japan), planP1 (rendezvous point : Germany), planP1 (rendezvous point : United States), planP1 (rendezvous point : Japan), plan-D, plan-K, plan-DU, plan-KM1).