Multi-byte character corruption issue affecting SORACOM Harvest Data
Incident Report for SORACOM
Resolved
(English follows Japanese)
日本時間 12/6 16:20 頃から 22:00 まで、SORACOM Harvest Data に送信されたデータにおいて日本語などのマルチバイト文字を含むデータが文字化けを起こす事象が発生していました。
原因の対処とその経過観察が完了しており、現在は平常通りご利用いただけます。このたびはご迷惑をおかけし、誠に申し訳ございませんでした。

詳細なタイムラインは以下のとおりです。
- 2021-12-06 16:20 JST 問題の開始
- 2021-12-06 20:23 JST 問題の認知、調査開始
- 2021-12-06 20:50 JST 原因の特定と対処開始
- 2021-12-06 22:00 JST 問題の回復および経過観察の開始
- 2021-12-06 23:00 JST 問題の完全な回復を確認

---
The issue affecting multi-byte characters sent to our Harvest Data service which began on 2021-12-06 07:20 UTC has been resolved as of 2021-12-06 13:00 UTC.
The service is now operating normally. We sincerely apologize for any inconvenience caused during this time. A detailed timeline follows.

- 2021-12-06 07:20 UTC: Incident began.
- 2021-12-06 11:23 UTC: Began to investigate.
- 2021-12-06 11:50 UTC: Identified root causes and started mitigation.
- 2021-12-06 13:00 UTC: Recovered the incident and continued monitoring
- 2021-12-06 14:00 UTC: Confirmed overall recovery.
Posted Dec 06, 2021 - 23:00 JST
Monitoring
(English follows Japanese)
SORACOM Harvest Data に送信された一部のデータにおいてマルチバイト文字を含むデータが文字化けを起こす事象について、原因の特定と対処が完了しました。
現在、通常どおりのサービスレベルに戻るまで経過を観察しています。完全な復旧が確認されたら改めてこちらのページでお知らせいたします。

---
Our engineers have identified the root cause of the issue affecting multi-byte characters sent to our Harvest Data service. A fix has been implemented and we are currently monitoring the recovery of the Harvest Data service. A new update will be issued once we have confirmed that the service has been fully restored.
Posted Dec 06, 2021 - 22:05 JST
Identified
日本時間 12/6 16:20 頃から SORACOM Harvest Data に送信されたデータにおいて日本語などのマルチバイト文字を含むデータが文字化けを起こす事象が発生しています。エンジニアチームが対応しています。

Our engineering team has observed that data sent to SORACOM Harvest Data is garbled. This includes multi-byte characters and has been occurring since 2021-12-06 07:20 UTC. Soracom Engineers are operating the issue and will update the status as soon as the matter is resolved. We appreciate your comprehension on the matter.
Posted Dec 06, 2021 - 21:14 JST
This incident affected: Harvest Data (plan01s (rendezvous point : Germany), plan01s (rendezvous point : United States), plan01s (rendezvous point : Japan), planX1 (rendezvous point : Germany), planX1 (rendezvous point : United States), planX1 (rendezvous point : Japan), planP1 (rendezvous point : Germany), planP1 (rendezvous point : United States), planP1 (rendezvous point : Japan), planX2 (rendezvous point : Japan), plan-D, plan-K, plan-DU, plan-KM1).